Results 1 to 12 of 12

Thread: Problems with Rig blaster Plus I

  1. #1

    Default Problems with Rig blaster Plus I

    I am having some trouble with my Rigblaster Plus (Original Version).

    First I plug in the power adapter and connect the DC power to the Rigblaster; the device power on.

    Next, I wired the jumpers and connected them according to the manual. I connected the Rigblaster to my radio via the mic cable, plugged in my mic into the front of the Rig Blaster, and pressed the PTT button on the mic. All is nominal there.

    Then I connected the USB to serial adapter to my computer and then the serial cable to the Rigblaster. I also made sure to connect the computer's audio line out to Rigblaster's audio line in. The adapter itself shows up in the device manager, but there is where my luck ends.

    Not matter what drivers are installed (I tried the ones from West Mountain Radio), what COM port is selected in the software, what software I use, what baud rate is selected for the adapter, what settings are set on the radio itself, or even what computer I use. The radio never enters transmit mode and no power is being sent out of the radio (even when I manually select transmit mode on the rig itself.) VOX mode doesn't seem to do much either.

    I know it is not a problem with the interface itself because using two identical Rigblasters produced the same results.

    Both computers I tried are Intel based systems running Windows 10, and my rig is an Icom IC-725.

    What is it that I may be doing wrong? Have I scrambled up the connections? I am using the wrong drivers?

  2. #2

    Join Date
    Apr 2019
    Location
    INDIANA
    Posts
    78

    Default

    You may already have this, but a double check for cable routing never hurts...

    Also make sure that the internal jumpers are set for your mic pin layout. If you need the diagrams for that let me know.

    Sent from my SM-S767VL using Tapatalk
    Last edited by KD9KVS; Wed 29th May 2019 at 01:58.
    73s, God bless and good day. KD9KVS
    I have a brain injury.
    I am not my brain injury.
    This does not define me.

  3. #3

    Default

    Quote Originally Posted by KD9KVS View Post
    You may already have this, but a double check for cable routing never hurts...

    Also make sure that the internal jumpers are set for your mic pin layout. If you need the diagrams for that let me know.

    Sent from my SM-S767VL using Tapatalk
    Hmm... Maybe that is the problem, could you send me the link to the digram?

  4. #4

    Default FIXED!

    Turns out, it was a problem with the serial keying jumper block! I overlooked that part of the manual.

    I feel real stupid now, cuz now I have two Rigblasters for no good reason...

  5. #5

    Join Date
    Apr 2019
    Location
    INDIANA
    Posts
    78

    Default

    Quote Originally Posted by maalikm View Post
    Hmm... Maybe that is the problem, could you send me the link to the digram?
    http://radiomanual.info/schemi/ACC_p...user_K1UHF.pdf

    This should set you up if you still need it, as far as having two, I'm always open to donations it sounds like you might be set. I am glad for you.

    Sent from my SM-S767VL using Tapatalk
    73s, God bless and good day. KD9KVS
    I have a brain injury.
    I am not my brain injury.
    This does not define me.

  6. #6

    Default

    You could always set up a laptop with the other one for field day.......

  7. #7

    Join Date
    Apr 2019
    Location
    INDIANA
    Posts
    78

    Default

    I should add, don't feel stupid because you missed something. It happens. You did a wise thing asking for help, and resolved your issue so you have a fully functional station to the level you desire.

    Sent from my SM-S767VL using Tapatalk
    73s, God bless and good day. KD9KVS
    I have a brain injury.
    I am not my brain injury.
    This does not define me.

  8. #8

    Default

    Having got my Rigblaster Plus setup, I dabbled a little in PSK31 and have had 3 QSOs so far. However, I have a troubling question...

    How much power can I run PSK31 on my Icom IC-725 before I damage it? I am using no external amplifier.

    Is there any safe amount of time to run full power and if so what is it?

    I ran the full 100 watts at times without any heating or reports of garbled signals, but something tells me I'm doing it wrong.

    Any help would be very appreciated.
    Last edited by maalikm; Fri 31st May 2019 at 03:14.

  9. #9

    Join Date
    Apr 2019
    Location
    INDIANA
    Posts
    78

    Default

    I have not personally run psk31, but I would assume you can transmit for as long as a maximum duty cycle of what your radio will permit. I remember (after checking, double checking, and then checking again to be sure, and I may still be wrong!!!) mine is 30 on 30 off on ssb 100watt. I would find the duty cycle and stick with that unless you have modified it to run longer without damage. I did find some tips for running psk31 that may help you.

    http://www.arrl.org/news/10-tips-for...1-digital-mode

    Hope this gets you in the right direction. I'll have a look to see if I can find that information on your radio.


    Sent from my SM-S767VL using Tapatalk
    73s, God bless and good day. KD9KVS
    I have a brain injury.
    I am not my brain injury.
    This does not define me.

  10. #10

    Join Date
    Apr 2019
    Location
    INDIANA
    Posts
    78

    Default

    Here us a review of someone using it for sstv, I'll copy a bit of it and post the link if you want the full review...

    "The unit lacks ALC indication on its meter, using the brightness of the TX indicator lamp instead; meaning you have to add your own meter to monitor the ALC or be very careful with your power output. The rig does have an RF Power adjustment in addition to the microphone level, but it appears to just fix the ALC bias. Since I adjust my power output from digital modes using the PC, this isn't an issue. I've not found a stated duty cycle for the unit, but many hours of SSTV at 90W has never been an issue.*"

    (Source) https://www.eham.net/reviews/detail/...bcctgtkpkq6691

    I hope this gives you the information you are looking for.

    Sent from my SM-S767VL using Tapatalk
    73s, God bless and good day. KD9KVS
    I have a brain injury.
    I am not my brain injury.
    This does not define me.

  11. #11

    Default

    Thank you all for your advice! Partly thanks to y'all, I made over 7 PSK31 contacts since getting everything set up. Its working much better than with SSB Voice!
    Until later! 73

  12. #12

    Join Date
    Apr 2019
    Location
    INDIANA
    Posts
    78

    Default

    Awesome work!!!

    Sent from my SM-S767VL using Tapatalk
    73s, God bless and good day. KD9KVS
    I have a brain injury.
    I am not my brain injury.
    This does not define me.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •