Results 1 to 2 of 2

Thread: Kensood TS-2000 PTT problem

  1. #1

    Default Kensood TS-2000 PTT problem

    My PTT indicator isn't moving between the main display and the sub display. The CTRL is moving but not the PTT. I did a Full and Partial reset with no change. I've disconnected the microphone and the problem still exists. Also when cycling through the HF bands, the radio hangs up when I'm on 20 meters and I have to shut off the radio to release it. Worked fine yesterday when I worked the MARS Crossband test. Today something is wrong.

  2. #2

    Default PTT question

    Mr. Vlado up in Asheville NC repaired my TS-2000 in a timely manner and wasn't very expensive. Even with everything unplugged, lightning somehow still seemed to get into the radio and caused a power surge that caused damage to some components. Radio has checked out just fine and is ready to go.

    I could not find out how to close this thread

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •