Results 1 to 4 of 4

Thread: Arduino APRS Transmitter

  1. #1

    Default Arduino APRS Transmitter

    I am working on a weather balloon project and I'm trying to figure out my GPS transmitter. I'm using a Radiometrix HX1 radio module with an Arduino Uno 9v, 1A power supply. At this point it's all plugged into a breadboard as I'm still testing everything. For the antenna I'm using a 1/2 wave monopole whip. The antenna is connected to an SMA connector soldered to a PCB with soldered jumper wires going to the antenna pins on the HX1.

    Here is a picture of what I've put together, minus the temperature sensors and the buzzer...
    https://cdn.sparkfun.com/assets/lear..._fritzing1.png

    If anyone's curious about the code, it can be found here...
    https://github.com/sparkfun/SparkFun_Trackuino

    Everything complies and uploads fine to the Arduino. The GPS locks to multiple satellites and it appears to transmit fine.

    For testing I've got a USB SDR dongle running SDRConsole(v2), Packet Engine Pro, and APRSIS32 on Windows 10.

    I've had no problems picking up APRS signals with the SDR, decoding the messages on Packet Engine, and mapping it on APRSIS32. However... when the SDR picks up the transmission from the Arduino, I get nothing on Packet Engine and nothing on the map. The transmission also sounds a bit different from others that I've heard. Other signals sound like a fax, defiantly data. Mine sounds more like a brief beep lasting about a second. I feel like I'm doing something wrong and can't pinpoint it. My best guess is that for some reason it's not transmitting correctly. I would really appreciate any help that anyone can offer! Thanks!

  2. #2
    Super Moderator 5B4AJB's Avatar
    Join Date
    Mar 2008
    Location
    Meneou, Cyprus
    Posts
    2,195

    Default

    Do you have the packet baudrate set to 1200? sounds like you may have it set to 9600...

  3. #3

    Default

    You might want to consider a different antenna before you fly it. A half wave MONO pole is ANTI-resonant. If you have the space for a half wave, why not a DIpole? You can incorporate one quarter wave element into the balloon-to-payload tether and the other quarter wave element hanging below. Maybe that infinite SWR is shutting down the transmitter immediately through a protection circuit....

  4. #4

    Default

    Baud rate is good. Oscilloscope showed the signal going to the transmitter, so the code is good. Turns out the data pin on the HX1 was bent backwards and not plugged into the breadboard... So basically it was sending empty packets...

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •