I just purchased a IC-7300 and it's a superb radio. But, before I even connected it to power I opened up for full coverage according to this video: https://www.youtube.com/watch?v=4C14wbc5sJY
When I connected power it started up fine and worked on all HF frequencies.

Some days later I wanted to try 6m because a friend of mine had a QSO there. I set the power to 5% and wanted to tune up my skyloop. But no power came out. I asked my friend about how his rig was opened up with a picture showing the diodes.
His rig was opened like this: http://radioaficion.com/cms/ic-7300-...-modification/

So I picked out the D416 as well, did a full reset but still no power out. The internal SWR meter shows full scale and the power out drops dramatically over 33MHz. At 35MHz nothing comes out and above that nothing at all.
Now I just want to hear if anyone has a clue what's going on?

I can't find anything that tells me what the problem is. The SWR detector is after the LPF so it can't be the LPF making a fuzz. Please send me a pm if you know anything about this.

73 de Barney