Results 1 to 8 of 8

Thread: Need help with Yaesu FT-60

  1. #1

    Default Need help with Yaesu FT-60

    I have a Yaesu FT-60 that I use with a headset. Just as quickly as it worked it now doesn't. I don't know if it is the headset or the radio. Now when I plug in the headset, the volume must be turned up all the way to barely hear the audio. Without the headset, I can brake squelch and the volume works fine. The key pad has been locked so I doubt that I have changed any settings. The headset I use is a fairly inexpensive 1 and have considered purchasing another to see if something might have happened, but....Has anyone experienced a similar problem?

  2. #2

    Default

    Based on what you have said, my first thought is that it's the headset. What headset are you using?

  3. #3

    Default Re: Need help with Yaesu FT-60

    Finally got back in. It's a Coodio. Inexpensive. Bought another, should be here later today. If it works then have answered my question. If not, then will have to take to a radio shop in Amarillo and hope they don't keep it forever.

  4. #4

    Join Date
    Aug 2017
    Posts
    142

    Default

    Time to read the owners manual, you do have an owners manual - don't you? Sounds like you need to adjust the AF and the Squelch..
    It isn't a CB radio, you can't just turn it on and use it and expect it to work..

  5. #5

    Default Need help with Yaesu FT-60

    Sixmeters, well Mr. know it all. It was the headset, not the radio. Maybe you should just keep your mouth shut if all you can do is criticize.

  6. #6

    Default

    Did the replacement one work or not?

  7. #7

    Default

    You can't just plug it in and it will work? Course you can! A headset is hardly something that needs tweaking - not a single one of the radios I won has any programming modes that allow adjustment for how loud the headsets connected to the socket can be? They are plug and play - they are not universal - a headset for a Kenwood won't necessarily work on a different brand radio. Basic connection differences and they are not software programmable.

  8. #8

    Join Date
    Aug 2017
    Posts
    142

    Default

    Here is a funny antidote for you to laugh about..

    When I bought my Kenwood TS 590S, I hooked it to an antenna and a power supply and turned it on and could hear stuff but it wouldn't transmit.

    Came to find out that Kenwood ships it like that on purpose so that when dummies like me, that gets into a big hurry to use it and doesn't read the owners manual first, doesn't burn it up when they connect it to the wrong antenna, or try to use it without a antenna even being hooked up. Just when I was getting ready to box it back up and ship it back to HRO, I read the manual, went thru the menu's, set the parameters, and everything worked.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •