Results 1 to 5 of 5

Thread: iCOM 5100 WILL NOT UPDATE FIRMWARE

  1. #1

    Default iCOM 5100 WILL NOT UPDATE FIRMWARE

    Hello thanks for the interest.

    I have DStar problems with my Icom 5100 and it was suggested I should update the firmware as it is original and requires to be updated.

    The instructions state on downloading the Firmware that to put the 5100 into update firmware mode requires you to hold in the QUICK button at the same time pressing the ON switch this turning on the firmware update capability. This does not do 'as it says on the tin' and the TX just goes each time to the programs listings.

    I have completely run out of ideas now and seek ideas on how I may eventually be able to upgrade the firmware.

    Thanks for any help

    73 de Peter G8CVF

  2. #2
    Super Moderator 5B4AJB's Avatar
    Join Date
    Mar 2008
    Location
    Meneou, Cyprus
    Posts
    1,999

    Default

    What does iCOM have to say about it?

  3. #3

    Default

    Quote Originally Posted by Pete View Post
    Hello thanks for the interest.
    I have DStar problems with my Icom 5100 and it was suggested I should update the firmware as it is original and requires to be updated.
    The instructions state on downloading the Firmware that to put the 5100 into update firmware mode requires you to hold in the QUICK button at the same time pressing the ON switch this turning on the firmware update capability. This does not do 'as it says on the tin' and the TX just goes each time to the programs listings.
    I have completely run out of ideas now and seek ideas on how I may eventually be able to upgrade the firmware.
    Thanks for any help
    73 de Peter G8CVF
    Make sure the rig is connected to the computer before trying to put it firmware mode.

    https://www.youtube.com/watch?v=8Uqh3HpkHTk

    Ben

  4. #4

    Default Success all's well.

    Quote Originally Posted by KD3WB View Post
    Make sure the rig is connected to the computer before trying to put it firmware mode.

    https://www.youtube.com/watch?v=8Uqh3HpkHTk

    Ben

    After a terrible headache I found the problem. Icom wanted me to send the 5100 to them and said as they are very busy it could take up to 3 months for them to even 'look at the problem' and couldn't estimate a charge either ugh!

    Anyway delighted to say when all else fails read the instructions, a simple firmware update is to manually push the QUICK button but not in my case a big NO but the HANDBOOK suggests pushing the RESET BUTTON on the back of the display (I didn't even know there was one). Pushing the button did not create a faint click that the button is operative, it wasn't it was jammed on, a change of switch and all's well.

    73 de Peter G8CVF

  5. #5

    Default

    Sorry I should have replied to your kind message but I was immediately hospitalized and was poorly for a long time completely forgetting the question was posted sorry.

    The problem is now sorted as per my new message posted today.

    73 de Peter G8cvf

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •