Results 1 to 5 of 5

Thread: TR-7625 no squelch until warmed up

  1. #1

    Default TR-7625 no squelch until warmed up

    Had this old dog given too me and the squelch dosn't work even at max, After a few mins it will work at max and the longer its left the less i have to swing the squelch control round to its shutoff point, After a long period of time [about 1hr or so] it will work at the 12 position and that is where it will stay, That is until its powered off for a while and the whole process starts again next time.

    What should i be looking for, I have the technical knowledge to check for voltages etc, But there is no info on this issue too be found anywhere.

    I am aware its a very old radio but apart from this minor issue it does still perform well and would like to get the squelch working properly again.

    Thanks

  2. #2

    Default

    Quote Originally Posted by StaplerUk View Post
    Had this old dog given too me and the squelch dosn't work even at max, After a few mins it will work at max and the longer its left the less i have to swing the squelch control round to its shutoff point, After a long period of time [about 1hr or so] it will work at the 12 position and that is where it will stay, That is until its powered off for a while and the whole process starts again next time.

    What should i be looking for, I have the technical knowledge to check for voltages etc, But there is no info on this issue too be found anywhere.

    I am aware its a very old radio but apart from this minor issue it does still perform well and would like to get the squelch working properly again.

    Thanks
    Did you ever find the solution? Mine is doing the exact same thing.

    Chris

  3. #3
    Super Moderator 5B4AJB's Avatar
    Join Date
    Mar 2008
    Location
    Meneou, Cyprus
    Posts
    2,258

    Default

    sounds like a leaking capacitor somewhere...

  4. #4

    Default

    Quote Originally Posted by 5B4AJB View Post
    sounds like a leaking capacitor somewhere...
    I looked at the schematic. The only electrolytic cap that is in the squelch circuit (upon quick glance anyhow) is C62, a 47uF 10v cap.
    That might be a good place to start.

    EDIT: ignore this... I was looking at the wrong board. There is more than one Q21! C62 has nothing to do with it. I will look at the x44-1320-10 board schematic tonight. Sorry for the confusion.
    Last edited by brandon lind; Wed 3rd Apr 2019 at 05:29. Reason: totally wrong

  5. #5

    Default

    My post above is wrong. I looked at the wrong board schematic for Q21. I will see if anything stands out on the other schematic tonight. Sorry for the confusion.


    EDIT: Take a look at C126 (4.7uF 16v), C127 (3.3uF 50v) and C123 (0.1uF 35v) on the TX/RX board (X44-1320-10).
    Not sure what made me look back at it but I'm glad I did. Sorry if I made you pull C62 for nothing. I wish the designers wouldn't use the same part label more than once in a radio, there's no shortage of numbers...
    Last edited by brandon lind; Wed 3rd Apr 2019 at 05:42.

Similar Threads

  1. Replies: 1
    Last Post: Thu 20th Dec 2012, 22:18
  2. alinco dj190 cant figure out squelch
    By motorman3000 in forum Alinco
    Replies: 2
    Last Post: Sun 12th Sep 2010, 16:22
  3. Replies: 2
    Last Post: Fri 10th Sep 2010, 10:22

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •